46 lines
1007 B
Nix
46 lines
1007 B
Nix
{
|
|
description = "My NeoVim configuration";
|
|
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
|
|
flake-parts.url = "github:hercules-ci/flake-parts";
|
|
|
|
nixvim = {
|
|
url = "github:nix-community/nixvim";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
};
|
|
|
|
outputs = {
|
|
nixvim,
|
|
flake-parts,
|
|
...
|
|
} @ inputs:
|
|
flake-parts.lib.mkFlake {inherit inputs;} {
|
|
systems = ["aarch64-linux" "x86_64-linux" "aarch64-darwin" "x86_64-darwin"];
|
|
|
|
perSystem = {
|
|
system,
|
|
pkgs,
|
|
...
|
|
}: let
|
|
nixvim' = nixvim.legacyPackages.${system};
|
|
nvim = nixvim'.makeNixvimWithModule {
|
|
inherit pkgs;
|
|
module = ./config;
|
|
};
|
|
in {
|
|
checks = {
|
|
default = nixvim.lib.${system}.check.mkTestDerivationFromNvim {
|
|
inherit nvim;
|
|
name = "A nixvim configuration";
|
|
};
|
|
};
|
|
|
|
formatter = pkgs.alejandra;
|
|
|
|
packages.default = nvim;
|
|
};
|
|
};
|
|
}
|