43 lines
704 B
Nix
43 lines
704 B
Nix
{
|
|
config = {
|
|
performance = {
|
|
byteCompileLua = {
|
|
enable = true;
|
|
plugins = true;
|
|
};
|
|
};
|
|
|
|
clipboard.providers.wl-copy.enable = true;
|
|
|
|
opts = {
|
|
number = true;
|
|
relativenumber = true;
|
|
|
|
tabstop = 2;
|
|
softtabstop = 2;
|
|
showtabline = 2;
|
|
expandtab = true;
|
|
|
|
smartindent = true;
|
|
shiftwidth = 2;
|
|
breakindent = true;
|
|
|
|
cursorline = true;
|
|
scrolloff = 8;
|
|
|
|
mouse = "a";
|
|
|
|
foldmethod = "manual";
|
|
foldenable = false;
|
|
linebreak = true;
|
|
|
|
showmode = false;
|
|
spell = false;
|
|
swapfile = false;
|
|
timeoutlen = 300;
|
|
termguicolors = true;
|
|
cmdheight = 0;
|
|
};
|
|
};
|
|
}
|