44 lines
897 B
Nix
44 lines
897 B
Nix
{
|
|
plugins.neo-tree = {
|
|
enable = true;
|
|
sources = ["filesystem" "buffers" "git_status" "document_symbols"];
|
|
addBlankLineAtTop = false;
|
|
|
|
filesystem = {
|
|
bindToCwd = true;
|
|
};
|
|
|
|
defaultComponentConfigs = {
|
|
indent = {
|
|
withExpanders = true;
|
|
expanderCollapsed = "";
|
|
expanderExpanded = "";
|
|
expanderHighlight = "NeoTreeExpander";
|
|
};
|
|
|
|
gitStatus = {
|
|
symbols = {
|
|
added = " ";
|
|
conflict = " ";
|
|
deleted = "";
|
|
ignored = " ";
|
|
modified = " ";
|
|
renamed = "";
|
|
staged = "";
|
|
unstaged = "";
|
|
untracked = " ";
|
|
};
|
|
};
|
|
};
|
|
};
|
|
|
|
keymaps = [
|
|
{
|
|
mode = ["n"];
|
|
key = "<C-n>";
|
|
action = "<cmd>Neotree toggle<cr>";
|
|
options = {desc = "Open/Close Neotree";};
|
|
}
|
|
];
|
|
}
|