nix-config/nixos/primordial/hardware-configuration.nix
2024-06-30 23:27:40 +02:00

54 lines
1.5 KiB
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

# Do not modify this file! It was generated by nixos-generate-config
{
config,
lib,
pkgs,
modulesPath,
...
}: {
imports = [];
boot.initrd = {
availableKernelModules = ["virtio_pci" "usbhid" "sd_mod" "sr_mod" "virtio_scsi"];
kernelModules = ["dm-snapshot"];
network.enable = true;
network.ssh = {
enable = true;
port = 222;
authorizedKeys = [
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIP8zNAXScQ4FoWNxF4+ALJXMSi3EbpqZP5pO9kfg9t8o patrick@NBG1-DC3-PC20-2017-10-24"
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIPflDQOANGhgtfo2psRwSFtY5ETHX/bsDmqrho3iX9jt root@arschlinux"
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIP6oGHBFD3wo16buPtdYDat911gydOw2oFj80fTXL1xo batzi@DESKTOP-8A2VTHL"
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAICK3otGMe8umxxJX5BbbBQ/+PQg37Puh0qjH8IILL95T patrick@mi"
];
hostKeys = ["/etc/secrets/initrd/ssh_host_ed25519_key"];
};
luks.devices = {
cryptroot = {
device = "/dev/disk/by-uuid/9f88803e-558d-4819-a223-df88396071fe";
preLVM = true;
};
};
};
boot.kernelModules = [];
boot.extraModulePackages = [];
fileSystems."/" = {
device = "/dev/disk/by-uuid/1837e2be-189b-49be-b518-8b2bbc49e27e";
fsType = "ext4";
};
fileSystems."/boot" = {
device = "/dev/disk/by-uuid/7E04-4E21";
fsType = "vfat";
};
swapDevices = [];
networking.useDHCP = lib.mkDefault true;
nixpkgs.hostPlatform = lib.mkDefault "aarch64-linux";
}